Rakenduse testimine erinevate IE versioonidega

  |   by kadriad   |   Blogi, javascript, php  |  No Comments

Oli vaja kontrollida ühe php-rakenduse töötamist erinevate Internet Exploreri versioonidega, et selgitada välja, kus viga tekib.

Algul üritasin lihtsalt ühte Windows XP arvutisse IE6-t installeerida, aga see ei õnnestunud.

Huvitaval kombel ei õnnestunud ka eemaldada olemasolevat IE8-t.

Leidsin sellise toreda asja:

http://utilu.com/IECollection/

Selle programmiga on võimalik oma arvutisse installeerida kõik IE versioonid alates esimesest.

Samuti saab kõik IE versioonid korraga lahti teha ja võrrelda – väga mugav.

Minu puhul selgus kurb tõsiasi, et php-rakendus tõesti IE6-ga ei toiminud – nimelt kasutatav javascript tõrkus.

Täiendus:

Siin on selline leht, kus on kõik variandid, kuidas ainult IE-le teha stylesheet-i:

http://css-tricks.com/132-how-to-create-an-ie-only-stylesheet/

Siin on selline leht, kus on näited, kuidas IE stiili parandada:

http://stylisticweb.com/design-tutorials/15-ie6-bugs-and-simple-solutions